Attention

Currently, if you are using a Verifone register type, you must have a version of 49 or higher to be compatible with this program.
You can purchase the service if your version is lower than 49, but you need to schedule an update.

Unfortunately, we cannot support your set-up at this time

For more information on the requirements for using Scan Data Loyalty, please click here.
Feel free to contact us if you have any questions, or we’ll reach out once we’re able to work with you.

Please confirm the information listed below

Attention

Currently if you are using a VeriFone register type you must have a version of 49 or higher to be compatible with this program.
You can purchase the service if your version is lower than 49, but you need to schedule an update.

Please confirm the information listed below

Attention

Currently if you are using a VeriFone register type you must have a version of 49 or higher to be compatible with this program.
You can purchase the service if your version is lower than 49, but you need to schedule an update.

Unfortunately, we cannot support your set-up at this time

For more information on the requirements for using Go Loyalty, please click here.
Feel free to contact us if you have any questions, or we’ll reach out once we’re able to work with you.

Please confirm the information listed below
* Required information